#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\bshift # )[a-f0-9]+(?:-[a-f0-9]+)+"
Local $sString = "1)Payment for shift # edc5df26-ad62-4685-ad80-4a3a60118479 receipt number #12345" & @CRLF & _
"2)Payment for shift # 394e3027-be5d-4369-91e6-88437c5330e0, adress: Germany, Frankfurt.." & @CRLF & _
"3)Payment for job shift # c921e015-74b2-4df2-84b2-e546a636272f"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")