re = /(?<=\bshift # )[a-f0-9]+(?:-[a-f0-9]+)+/m
str = '1)Payment for shift # edc5df26-ad62-4685-ad80-4a3a60118479 receipt number #12345
2)Payment for shift # 394e3027-be5d-4369-91e6-88437c5330e0, adress: Germany, Frankfurt..
3)Payment for job shift # c921e015-74b2-4df2-84b2-e546a636272f'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end