import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?'stat'[a-zA-Z]*)|(?'ip'\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3})|(?'desc'was found on a blacklist|has not changed)|$";
final String string = "Updated ad.ip.lc to 93.184.216.34 in 0.041 seconds\n"
+ "ERROR: Address 93.184.216.34 has not changed.\n"
+ "ERROR: The IP 98.150.108.228 was found on a blacklist - please contact an administrator if you believe this is in error";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}