import re
regex = re.compile(r"^(?'stat'[a-zA-Z]*)|(?'ip'\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})|(?'desc'was found on a blacklist|has not changed)|$", flags=re.MULTILINE)
test_str = ("Updated ad.ip.lc to 93.184.216.34 in 0.041 seconds\n"
"ERROR: Address 93.184.216.34 has not changed.\n"
"ERROR: The IP 98.150.108.228 was found on a blacklist - please contact an administrator if you believe this is in error")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")