package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`access-guide/([^/]*(?:university|universities|college|colleges)[^/]*)`)
var str = `http://www.disabledgo.com/access-guide/the-university-of-manchester/176-waterloo-place-2
http://www.disabledgo.com/access-guide/kingston-university/coombehurst-court-2
http://www.disabledgo.com/access-guide/kings-college-london/franklin-wilkins-building-2
http://www.disabledgo.com/access-guide/redbridge-college/brook-centre-learning-resource-centre`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}