import re
regex = re.compile(r"access-guide/([^/]*(?:university|universities|college|colleges)[^/]*)")
test_str = ("http://www.disabledgo.com/access-guide/the-university-of-manchester/176-waterloo-place-2\n\n"
"http://www.disabledgo.com/access-guide/kingston-university/coombehurst-court-2\n\n"
"http://www.disabledgo.com/access-guide/kings-college-london/franklin-wilkins-building-2\n\n"
"http://www.disabledgo.com/access-guide/redbridge-college/brook-centre-learning-resource-centre")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")