const regex = /<a href=\S+|\b((?:https?:(?:\/{1,3}|[a-z0-9%])|[a-z0-9.\-]+[.](?!js)[a-z]{2,6}\/)(?:[^\s()<>{}\[\]]+)(?:[^\s`!()\[\]{};:'".,<>?«»“â€â€˜â€™])|(?:(?<!@)[a-z0-9]+(?:[.\-][a-z0-9]+)*[.](?!js)[a-z]{2,6}\b\/?(?!@)))/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a href=\\S+|\\b((?:https?:(?:\\\/{1,3}|[a-z0-9%])|[a-z0-9.\\-]+[.](?!js)[a-z]{2,6}\\\/)(?:[^\\s()<>{}\\[\\]]+)(?:[^\\s`!()\\[\\]{};:\'".,<>?«»“â€â€˜â€™])|(?:(?<!@)[a-z0-9]+(?:[.\\-][a-z0-9]+)*[.](?!js)[a-z]{2,6}\\b\\\/?(?!@)))', 'gi')
const str = `<a href="http://www.google.com">Google</a>
www.google.com
google.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}