re = /<td>(.*?)<\/td>|<div.*?>(.*?)<\/div>/
str = '<td>SOME OF THE STRINGS COULD BE HERE</td>
<div style="line-height: 100%;margin:0;padding:0;">SOME STRINGS COULD ALSO BE HERE</div>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end