import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=from..)(.*)(?=module)(.*)(module)";
final String string = "import { service1 } from \"./module/1.service\";\n"
+ "import { service2 } from \"../module/2.service\";\n"
+ "import { service3 } from \"../../module/3.service\";\n"
+ "import { service4 } from \"../../../module/4.service\";\n"
+ "import { service5 } from \"../../../../module/5.service\";\n"
+ "import { service6 } from \"../../../../../module/6.service\";\n"
+ "import { service7 } from \"../../../../../../module/7.service\";\n"
+ "import { service8 } from \"../../../../../../../module/8.service\";\n\n"
+ "import { service9 } from \"@module/9.service\";\n"
+ "import { service10 } from \"@module/10.service\";\n"
+ "import { service11 } from \"@module/11.service\";";
final String subst = "@module";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}