const regex = /(?<=from..)(.*)(?=module)(.*)(module)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=from..)(.*)(?=module)(.*)(module)', 'g')
const str = `import { service1 } from "./module/1.service";
import { service2 } from "../module/2.service";
import { service3 } from "../../module/3.service";
import { service4 } from "../../../module/4.service";
import { service5 } from "../../../../module/5.service";
import { service6 } from "../../../../../module/6.service";
import { service7 } from "../../../../../../module/7.service";
import { service8 } from "../../../../../../../module/8.service";
import { service9 } from "@module/9.service";
import { service10 } from "@module/10.service";
import { service11 } from "@module/11.service";`;
const subst = `@module`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);