using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@\[\[(?<name>.+?)\]\]";
string input = @"my first name is @[[Rameez]] and second name is @[[Rami]].
Did I forget to mention that my name is @[[Rameez]]?";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}