$re = '/@\[\[(?<name>.+?)\]\]/';
$str = 'my first name is @[[Rameez]] and second name is @[[Rami]].
Did I forget to mention that my name is @[[Rameez]]?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);