const regex = new RegExp('href=\\"https://download\\.sketchup\\.com/SketchUp-2025-([0-9]+(-[0-9]+)+)\\.dmg\\"', 'gm')
const str = `<a href="https://download.sketchup.com/SketchUp-2025-0-570-242.dmg">Download for SketchUp 2025 for MacOS</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}