use strict;
my $str = '<a href="https://download.sketchup.com/SketchUp-2025-0-570-242.dmg">Download for SketchUp 2025 for MacOS</a>';
my $regex = qr/href=\"https://download\.sketchup\.com/SketchUp-2025-([0-9]+(-[0-9]+)+)\.dmg\"/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}