re = /\w+$/m
str = '\\\\share\\david\\test\\test.doc
\\\\sharre\\david.jones\\test\\test.doc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end