using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(PackageQuantity:|(Servings)?PerContainer:|(Servings)?PerPackage:)[a-zA-Z.]*(\d+)";
string input = @"ServingsPerContainer:about11
PackageQuantity:approx.12
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}