re = /(PackageQuantity:|(Servings)?PerContainer:|(Servings)?PerPackage:)[a-zA-Z.]*(\d+)/
str = 'ServingsPerContainer:about11
PackageQuantity:approx.12
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end