const regex = /[^A-Za-z.0-9:;$-]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^A-Za-z.0-9:;$-]+', 'g')
const str = `This is a test.
This is a newline.
this is another newline. This is a, comma`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);