$re = '/[^A-Za-z.0-9:;$-]+/';
$str = 'This is a test.
This is a newline.
this is another newline. This is a, comma';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;