use strict;
my $str = '$str=\'\\add[sometext]{\\begin{equation}\\label{eqn:3}
f_{1} =
\\begin{cases}}
\\beta_{1} + \\beta_{2}f_{2} & f_{2}\\leq \\gamma\\\\
\\beta_{1} + \\beta_{2}\\gamma + \\beta_{4}(f_{2}-\\gamma) & f_{2} >\\gamma
\\end{cases}sdsdssd,
\\end{equation}}\'';
my $regex = qr/\{([\s\S]*)\}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}