// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\{([\s\S]*)\}").unwrap();
let string = "$str='\\add[sometext]{\\begin{equation}\\label{eqn:3}
f_{1} =
\\begin{cases}}
\\beta_{1} + \\beta_{2}f_{2} & f_{2}\\leq \\gamma\\\\
\\beta_{1} + \\beta_{2}\\gamma + \\beta_{4}(f_{2}-\\gamma) & f_{2} >\\gamma
\\end{cases}sdsdssd,
\\end{equation}}'";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}