$re = '/"((?:\\\\.|[^"\\\\])*)"/m';
$str = '"one\\"","two","three"
"one","two","three"
"one","two","thre\\"e"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);