re = /"((?:\\.|[^"\\])*)"/m
str = '"one\\"","two","three"
"one","two","three"
"one","two","thre\\"e"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end