$re = '/(?<![a-zA-Z_-])(?:error|missing|unknown|except|not found|fail|unavailable|issue|problem|fault|code 1|crash)/im';
$str = 'super faulty
crashlandish';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);