re = /(?<![a-zA-Z_-])(?:error|missing|unknown|except|not found|fail|unavailable|issue|problem|fault|code 1|crash)/im
str = 'super faulty
crashlandish'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end