$re = '/(\bdog\b)|(\bcat\b)/m';
$str = 'dog cat catdog dogcat 1dog file.dog dog.cat dog-cat banana bananacat ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);