re = /(\bdog\b)|(\bcat\b)/m
str = 'dog cat catdog dogcat 1dog file.dog dog.cat dog-cat banana bananacat '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end