using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[^<]+|<a\b[^>]*>.*?</a>)*((ftp|http|https):\/\/(\w+:{0,1}\w*@)?(\S+)(:[0-9]+)?(\/|\/([\w#!:.?+=&%@!\-\/]))?)[^< ,""'>]";
string input = @"I was surfing http://www.google.com, where I found my tweet, check it out <a href=""http://tinyurl.com/blah"">http://tinyurl.com/blah</a>
<span>http://www.google.com</span>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}