re = /(?:[^<]+|<a\b[^>]*>.*?<\/a>)*((ftp|http|https):\/\/(\w+:{0,1}\w*@)?(\S+)(:[0-9]+)?(\/|\/([\w#!:.?+=&%@!\-\/]))?)[^< ,"'>]/m
str = 'I was surfing http://www.google.com, where I found my tweet, check it out <a href="http://tinyurl.com/blah">http://tinyurl.com/blah</a>
<span>http://www.google.com</span>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end