$re = '/assertTextValue\(assert\, find\(([^\)]+)\)/';
$str = 'assertTextValue(assert, find(\'.js-summary-title\'), \'Medical\', \'Should have correct title\');
assertTextValue(assert, find(\'.js-summary-title\', summary), \'Motor\', \'Should have correct title\');
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);