// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"assertTextValue\(assert\, find\(([^\)]+)\)").unwrap();
let string = "assertTextValue(assert, find('.js-summary-title'), 'Medical', 'Should have correct title');
assertTextValue(assert, find('.js-summary-title', summary), 'Motor', 'Should have correct title');
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}