using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\+?\d[\h(-]{0,3})? # Remove country code, ""+"", "" "", and ""(""
(\d{3}) # Area code
[\h)-.]{0,3} # Remove ""-"", "" "", ""."", and "")""
(\d{3}) # Three digits
[\h-.]{0,3} # Remove ""-"", "" "", and "".""
(\d{4}) # Four digits";
string substitution = @"$2.$3.$4";
string input = @"+1 123 111 1111
+1-111-111-1234
+1 (111) 111-1111
1 111 111 1111
1-111-111-1111
1-(111) 111-4567
1111111111
111.111.8765
111-345-1111";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}