import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\+?\\d[\\h(-]{0,3})? # Remove country code, \"+\", \" \", and \"(\"\n"
+ "(\\d{3}) # Area code\n"
+ "[\\h)-.]{0,3} # Remove \"-\", \" \", \".\", and \")\"\n"
+ "(\\d{3}) # Three digits\n"
+ "[\\h-.]{0,3} # Remove \"-\", \" \", and \".\"\n"
+ "(\\d{4}) # Four digits";
final String string = "+1 123 111 1111\n"
+ "+1-111-111-1234\n"
+ "+1 (111) 111-1111\n"
+ "1 111 111 1111\n"
+ "1-111-111-1111\n"
+ "1-(111) 111-4567\n"
+ "1111111111\n"
+ "111.111.8765\n"
+ "111-345-1111";
final String subst = "$2.$3.$4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}