const regex = /\b(?P<id_1>a|b|c)\b(?:(?!\b(?:q|w)\b).)*(?P<id_2>q|w|)\b/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?P<id_1>a|b|c)\\b(?:(?!\\b(?:q|w)\\b).)*(?P<id_2>q|w|)\\b', 'ig')
const str = `a something* q b c w
a something* w
a
a w`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}