import re
regex = re.compile(r"\b(?P<id_1>a|b|c)\b(?:(?!\b(?:q|w)\b).)*(?P<id_2>q|w|)\b", flags=re.IGNORECASE)
test_str = ("a something* q b c w\n"
"a something* w\n"
"a\n"
"a w")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")