#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<\/aegn_condition[A-Za-z0-9 ]*>"
Local $sString = "<aegn_condition rhs="">" & @CRLF & _
"" & @CRLF & _
"</aegn_condition>" & @CRLF & _
"" & @CRLF & _
"</aegn_condition wibble>:w" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")