$re = '/<\/aegn_condition[A-Za-z0-9 ]*>/';
$str = '<aegn_condition rhs="">
</aegn_condition>
</aegn_condition wibble>:w
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);