$re = '/^[a-zA-Z](?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*[$\-_. +!*\'()])[a-zA-Z0-9$\-_. +!*\'()]{10,40}$/';
$str = 'Pas+ad123err0risoK
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);