re = /^[a-zA-Z](?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*[$\-_. +!*'()])[a-zA-Z0-9$\-_. +!*'()]{10,40}$/
str = 'Pas+ad123err0risoK
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end