#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\d+(?:\.\d+){3}"
Local $sString = "Gateway of last resort is 10.119.254.240 to network 10.140.0.0 " & @CRLF & _
"O E2 10.110.0.0 [160/5] via 10.119.254.6, 0:01:00, Ethernet2" & @CRLF & _
"D 10.67.10.0 [200/128] via 10.119.254.244, 0:02:22, Ethernet2" & @CRLF & _
"O E2 10.68.132.0 [160/5] via 10.119.254.6, 0:00:59, Ethernet2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")