package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d+(?:\.\d+){3}`)
var str = `Gateway of last resort is 10.119.254.240 to network 10.140.0.0
O E2 10.110.0.0 [160/5] via 10.119.254.6, 0:01:00, Ethernet2
D 10.67.10.0 [200/128] via 10.119.254.244, 0:02:22, Ethernet2
O E2 10.68.132.0 [160/5] via 10.119.254.6, 0:00:59, Ethernet2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}