#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!(.*\+){2})(?!(.*-){2})(?!(.*\*){2})[0-9*+-]+$"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
"+9720545455454" & @CRLF & _
"" & @CRLF & _
"056565656345" & @CRLF & _
"" & @CRLF & _
"03-43434344" & @CRLF & _
"" & @CRLF & _
"0546-4234234" & @CRLF & _
"" & @CRLF & _
"*9090" & @CRLF & _
"" & @CRLF & _
"+97203-0656534" & @CRLF & _
"" & @CRLF & _
"Meaning, I don't want to allow the user to gibberish everything together, like:" & @CRLF & _
"" & @CRLF & _
"+954-4343+3232*4343+-" & @CRLF & _
"" & @CRLF & _
"+-4343-+5454+9323+234" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")