re = /^(?!(.*\+){2})(?!(.*-){2})(?!(.*\*){2})[0-9*+-]+$/m
str = '
+9720545455454
056565656345
03-43434344
0546-4234234
*9090
+97203-0656534
Meaning, I don\'t want to allow the user to gibberish everything together, like:
+954-4343+3232*4343+-
+-4343-+5454+9323+234
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end