import re
regex = re.compile(r"[\r\n]+", flags=re.MULTILINE)
test_str = ("#EXTINF:-1 tvg-name=\"seedocs\" tvg-logo=\"RT\",RT\n\n\n\n\n\n"
"http://rt.ashttp14.visionip.tv/live/rt-global-live-HD/playlist.m3u8\n\n"
"#EXTINF:-1 tvg-name=\"hsn\" tvg-logo=\"hsn\",HSN TV\n\n"
"rtsp://hsn.mpl.miisolutions.net:1935/hsn-live01/_definst_/mp4:420p500kB31\n\n"
"#EXTINF:-1 tvg-name=\"us\" tvg-logo=\"us\",USTwit\n\n"
"http://bglive-a.bitgravity.com/twit/live/high\n\n"
"#EXTINF:-1 tvg-name=\"ALJAZEERA\" tvg-logo=\"aljazeera\",Aljazeera\n\n"
"rtmp://aljazeeraflashlivefs.fplive.net/aljazeeraflashlive-live/aljazeera_eng_high\n\n"
"#EXTINF:-1 tvg-name=\"bbc\" tvg-logo=\"bbc\",BBC World News\n\n\n\n"
"#EXTINF:-1 tvg-name=\"vevo\" tvg-logo=\"vevo\",Vevo\n\n"
"http://vevoplaylist-live.hls.adaptive.level3.net/vevo/ch1/06/prog_index.m3u8\n\n"
"#EXTINF:-1 tvg-name=\"vevo2\" tvg-logo=\"vevo2\",Vevo 2\n\n"
"http://vevoplaylist-live.hls.adaptive.level3.net/vevo/ch3/06/prog_index.m3u8\n\n"
"#EXTINF:-1 tvg-name=\"1HD\" tvg-logo=\"1HD\",1HD\n\n"
"rtmp://109.239.142.62/live/livestream3")
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)