// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[\r\n]+").unwrap();
let string = "#EXTINF:-1 tvg-name=\"seedocs\" tvg-logo=\"RT\",RT
http://rt.ashttp14.visionip.tv/live/rt-global-live-HD/playlist.m3u8
#EXTINF:-1 tvg-name=\"hsn\" tvg-logo=\"hsn\",HSN TV
rtsp://hsn.mpl.miisolutions.net:1935/hsn-live01/_definst_/mp4:420p500kB31
#EXTINF:-1 tvg-name=\"us\" tvg-logo=\"us\",USTwit
http://bglive-a.bitgravity.com/twit/live/high
#EXTINF:-1 tvg-name=\"ALJAZEERA\" tvg-logo=\"aljazeera\",Aljazeera
rtmp://aljazeeraflashlivefs.fplive.net/aljazeeraflashlive-live/aljazeera_eng_high
#EXTINF:-1 tvg-name=\"bbc\" tvg-logo=\"bbc\",BBC World News
#EXTINF:-1 tvg-name=\"vevo\" tvg-logo=\"vevo\",Vevo
http://vevoplaylist-live.hls.adaptive.level3.net/vevo/ch1/06/prog_index.m3u8
#EXTINF:-1 tvg-name=\"vevo2\" tvg-logo=\"vevo2\",Vevo 2
http://vevoplaylist-live.hls.adaptive.level3.net/vevo/ch3/06/prog_index.m3u8
#EXTINF:-1 tvg-name=\"1HD\" tvg-logo=\"1HD\",1HD
rtmp://109.239.142.62/live/livestream3";
let substitution = "\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}