import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?!(\\w)(\\w)\\2\\1).)*$";
final String string = "Match:\n\n"
+ "aesthophysiology\n"
+ "amphimictical\n"
+ "baruria\n"
+ "calomorphic\n\n"
+ "Don't Match\n\n"
+ "anallagmatic\n"
+ "bassarisk\n"
+ "chorioallantois\n"
+ "coccomyces\n"
+ "abba";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}