#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\\senator{})Bernie Sanders(?!\s*})"
Local $sString = "Bernie Sanders" & @CRLF & _
"\senator{Bernie Sanders}" & @CRLF & _
"The senator of Vermont is \senator{Bernie Sanders}." & @CRLF & _
"A \texttt{senator of Vermont} is Bernie Sanders." & @CRLF & _
"A senator of Vermont is \textit{Bernie Sanders}." & @CRLF & _
"\textit{Bernie Sanders} is a senator of Vermont." & @CRLF & _
"Is this the same Bernie Sanders?" & @CRLF & _
"Is Bernie Sanders a good senator?" & @CRLF & _
"Will we ever see a \textbf{President Bernie Sanders}?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")