import re
regex = re.compile(r"(?<!\\senator{})Bernie Sanders(?!\s*})", flags=re.MULTILINE)
test_str = ("Bernie Sanders\n"
"\\senator{Bernie Sanders}\n"
"The senator of Vermont is \\senator{Bernie Sanders}.\n"
"A \\texttt{senator of Vermont} is Bernie Sanders.\n"
"A senator of Vermont is \\textit{Bernie Sanders}.\n"
"\\textit{Bernie Sanders} is a senator of Vermont.\n"
"Is this the same Bernie Sanders?\n"
"Is Bernie Sanders a good senator?\n"
"Will we ever see a \\textbf{President Bernie Sanders}?")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")