const regex = /^([a-zA-Z]*)\\/u;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-zA-Z]*)\\\\', 'u')
const str = `AccountDB\\\\DB`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);