use strict;
my $str = 'AccountDB\\\\DB';
my $regex = qr/^([a-zA-Z]*)\\/up;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";